[LV2] Bikeshed: Conventional names for event control ports

David Robillard d at drobilla.net
Sun Jan 6 08:31:18 PST 2013

On Sat, 2013-01-05 at 17:20 -0600, Gabriel Beddingfield wrote:
> On Sat, Jan 5, 2013 at 2:56 PM, David Robillard <d at drobilla.net> wrote:
> > Perhaps "command" and "response"?  Being a functional nerd I don't like
> > the imperativeness of "command" so much, a "response" is quite a bit
> > more narrow than it should be (such a port can emit much more than just
> > responses) but this is the best I can come up with.
> Yeah, I think "command" is the best option.
> Instead of "response," how about "announce" or "broadcast"

"announce" is pretty good, but "response" pairs with "command" better.
I am currently using "notify" as a good middle ground that's a bit less

The least semantically overloaded option would be simply "receive" and
"send".  It's probably unlikely that *all* plugins use these names for
their main event ports, though (e.g. for some the input one is simply
"input"), so maybe being a bit semantically specific is okay...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part
URL: <http://lists.lv2plug.in/pipermail/devel-lv2plug.in/attachments/20130106/f6be18e2/attachment-0002.pgp>

More information about the Devel mailing list