[LV2] Bikeshed: Conventional names for event control ports

Gabriel Beddingfield gabrbedd at gmail.com
Sat Jan 5 15:20:44 PST 2013

On Sat, Jan 5, 2013 at 2:56 PM, David Robillard <d at drobilla.net> wrote:
> Perhaps "command" and "response"?  Being a functional nerd I don't like
> the imperativeness of "command" so much, a "response" is quite a bit
> more narrow than it should be (such a port can emit much more than just
> responses) but this is the best I can come up with.

Yeah, I think "command" is the best option.

Instead of "response," how about "announce" or "broadcast"

Or perhaps "slot"/"signal".  ("slot" is rgareus's idea.)  However,
"signal" (more than the others) might be confusing for non-technical
users -- who could think of a "signal" port as going either way.


More information about the Devel mailing list