[LV2] Bikeshed: Conventional names for event control ports

Gabriel Beddingfield gabrbedd at gmail.com
Sun Jan 6 15:22:27 PST 2013

On Sun, Jan 6, 2013 at 10:31 AM, David Robillard <d at drobilla.net> wrote:
> On Sat, 2013-01-05 at 17:20 -0600, Gabriel Beddingfield wrote:
>> On Sat, Jan 5, 2013 at 2:56 PM, David Robillard <d at drobilla.net> wrote:
>> > Perhaps "command" and "response"?  Being a functional nerd I don't like
>> > the imperativeness of "command" so much, a "response" is quite a bit
>> > more narrow than it should be (such a port can emit much more than just
>> > responses) but this is the best I can come up with.
>> Yeah, I think "command" is the best option.
>> Instead of "response," how about "announce" or "broadcast"
> "announce" is pretty good, but "response" pairs with "command" better.

Yeah, I understood that, but "response" implies that there is a
cause/effect relationship with the "command."  Since this relationship
is not always true, the terminology creates a problem.

> I am currently using "notify" as a good middle ground that's a bit less
> specific.

I like that one better.

> The least semantically overloaded option would be simply "receive" and
> "send".  It's probably unlikely that *all* plugins use these names for
> their main event ports, though (e.g. for some the input one is simply
> "input"), so maybe being a bit semantically specific is okay...

How about "listen" / "speak"?  Or "listen" / "notify"?  That kind of
respects the client/server relationship we're trying to represent.


More information about the Devel mailing list