[LV2] Bikeshed: Conventional names for event control ports
d at drobilla.net
Sat Jan 5 12:56:59 PST 2013
Simple aesthetic question, I'm looking for the best names to establish
as the conventional names and symbols for event-based plugin control.
Currently I'm using "control" and "notify", but some think this is
confusing and "control" conflicting with control ports may be less than
Perhaps "command" and "response"? Being a functional nerd I don't like
the imperativeness of "command" so much, a "response" is quite a bit
more narrow than it should be (such a port can emit much more than just
responses) but this is the best I can come up with.
The purpose of these ports is control of any and all plugin settings via
messages, and responding to those messages (which will eventually
include parameters as well). The ideal names are those most likely to
have people correctly guess this intent. I'd like to come up with a
nice single word pair to avoid "Control In" and "Control Out" (though
perhaps this is misguided?)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 836 bytes
Desc: This is a digitally signed message part
More information about the Devel