[LV2] Building plugin binaries for older macOS versions

Stefan Westerfeld stefan at space.twc.de
Thu May 31 06:35:40 PDT 2018


On Sun, May 27, 2018 at 03:51:49PM +0200, Robin Gareus wrote:
> On 05/27/2018 03:09 PM, Stefan Westerfeld wrote:
> > The question I have is: what do I need to do if I want to build a version of
> > the plugin that will also run on older macOS versions?
> [...]
> Generally speaking just an old SDK will be sufficient. For plain C you
> can use recent x-code with older SDKs, but C++ will be a problem (modern
> xcode only works with libc++).

Thanks for your comments, I think I've found a reasonable solution now. My
build system is macOS 10.13 with the standard xcode command line tools.

I use the -isysroot compiler flag to point clang at a macOS 10.9 SDK and
-mmacosx-version-min=10.9 to support any macOS >= 10.9. I also use a script
based on your zyn osx script to build all dependencies with these flags,
because of course using standard brew packages is no longer possible, since
every static library I need must be compiled to support macOS >= 10.9.

10.9 is the first SDK that has C++11 support, and SpectMorph uses C++11, so I
cannot support older macOS versions (10.8 and earlier) with this strategy, but
I can live with that.

   Cu... Stefan
Stefan Westerfeld, http://space.twc.de/~stefan

More information about the Devel mailing list