[LV2] Simplifying the Atom model

Stefan Kersten sk at k-hornz.de
Sat Feb 9 14:43:52 PST 2013

On 09/02/2013, at 22:37, David Robillard <d at drobilla.net> wrote:
> On Sat, 2013-02-09 at 12:40 +0100, Stefan Kersten wrote:
> [...]
>>> In short, I think it would be much more obvious if we simply had one
>>> "Object" type.
>>> The solution is to merge the classes, and use a signed int32_t as an ID,
>>> where positive is a URID, and negative is a blank node ID (essentially
>>> meaningless outside local context).
>> imho the current scheme is not confusing at all but rather makes the distinction between blanks and resources explicit instead of relying on a convention.
> The only difference is the ID, though.  In practice this means you get
> type == uris->atom_Resource || type == uris->atom_Blank everywhere, when
> you actually don't care about the type at all.

maybe just adding an is_object helper would do the trick? that's what i'm using in my code now.

> Fair enough, but people are very prone to just knee-jerk write this
> stuff off as "confusing", especially if it smells at all like RDF.  I
> suspect just "Object" would be much more palatable to these people.

i like the fact that the atom types have an rdf representation (the rdf turtle primer is a very  helpful resource and should maybe be linked from the docs somewhere).

i was wondering btw what's the rdf representation of a property's context field?


More information about the Devel mailing list