[Devel] Naming convention for preset bundles
d at drobilla.net
Sat Jan 7 18:49:12 PST 2012
I am currently working on implementing user-saved presets. For various
reasons I have come to the conclusion that it is probably/usually best
to save each preset to its own bundle (for one, this makes managing them
very simple for the user without requiring any special tools).
Since plugins and such also live in the same directory (i.e. anywhere in
LV2_PATH, typically ~/.lv2 here) it might be useful to have a naming
convention for user saved bundles so it's easy to keep track of things
and manage manually.
Suggestions? "Preset" and "State" are the more or less equivalent words
for the things being saved here, but we could perhaps also go with
something more generic for user saved bundles. I'm not sure.
Perhaps just tacking on an extension, like:
(Where "ps" is "preset" or "plugin state" if you like)?
More information about the Devel