[Devel] Fwd: [RFC] URID extension
gabrbedd at gmail.com
Fri Jul 22 11:35:48 PDT 2011
Oops... I accidentally replied off-list.
---------- Forwarded message ----------
From: Gabriel Beddingfield <gabrbedd at gmail.com>
Date: Thu, Jul 21, 2011 at 2:16 PM
Subject: Re: [Devel] [RFC] URID extension
To: David Robillard <d at drobilla.net>
> It was a mistake in the past to use the URI of the extension as the URI
> of the feature. A specific URI for the feature itself should be used,
> in this case http://example.org/rfc/urid#URIMap or whatever.
> I would use the names currently in use just to keep things clear,
> uri_to_id and id_to_uri.
Works for me.
> I could also go with map_uri and unmap_uri
> (perhaps better because they are shorter). Very obviously symmetrical
> function names are good.
> We could use a typedef for uint32_t just for documentation purposes.
> Following convention I guess it would be LV2_URID but that's a bit long
> and screamey.
> One possible non-trivial change would be to use two separate features
> (in this one extension) for mapping and unmapping, since it's more
> difficult/expensive to implement both... more logistical nuisance,
Why would a plugin need to or want to unmap a URI? And if plugin A
maps the uri, then then plugin B maps/refers to the same one... what
happens when A unmaps the URI?
Thus, I was thinking that unmapping would be an implementation detail
of the host implementation... based on a reference counting scheme.
More information about the Devel